[MUD-Dev] [DGN] [NEWBIE] Suggestions on (OO) Server Design.

Greg Munt greg.munt at btinternet.com
Sat Apr 6 12:55:18 CEST 2002


From: Kwon Ekstrom <justice at softhome.net>
> From: "Pure Krome" <muddev at world-domination.com.au>

> My mud is written in java, and uses a form of this, Java allows
> multiple inheritance in the form on interfaces.  I have a Token
> interface which defines things necessary for all mud objects, Mobs
> (Creatures in my system) and Items (Objects, the keyword is
> reserved and Item is more descriptive imo).

Object isn't a keyword, and isn't reserved. Having a type named (for
example) com.slimy.devmud.Object is quite legal. I'm not sure how
Item is more descriptive than Object. I'd use something like
WorldObject, and I find the name Token to be misleading - it makes
me think of string tokenisers and compiler compilers. Having said
that though, the actual names given to classes is so trivial that it
makes very strong opinions on the subject quite religious.

> I have an abstractToken which provides a default implementation of
> Token, which is extended by Room and NamedToken, NamedToken
> provides methods and fields to handle an object with names (as the
> name implies).  Creature (Mobiles) and Item (Objects) extend
> NamedToken.

Why is Room not a NamedToken? Do your rooms not have names?

> Java only supports single inheritance, with multiple interfaces...
> By the time they get to NamedToken there's about a dozen
> interfraces that get inherited.

A dozen? That sounds rather large to me. Would you care to talk
about the interfaces implemented by NamedToken?


_______________________________________________
MUD-Dev mailing list
MUD-Dev at kanga.nu
https://www.kanga.nu/lists/listinfo/mud-dev



More information about the mud-dev-archive mailing list